Bug report thread


Please report any bugs or strange behaviour.

Get Promesa

Buy Now
On Sale!
25% Off
$5.00 $3.75 USD or more

Comments

Log in with itch.io to leave a comment.

(1 edit)

When starting game, everything was working fine. I got to the part where I saw the grandfather and grandmother in the hallway and backed away from them, then the screen went black, then a white halo appeared in the middle of the screen with two black pixelated squares inside of it, and as I moved around, the black squares began to fill the screen. Once the screen was filled, I heard sounds, but no amount of movement, even ten minutes of trying, would cause anything to appear on screen. I can't see where I'm supposed to be or what I'm supposed to do. Quitting and re-entering didn't solve the problem.

Hey there, are you on Mac or Pc?

I believe what you're experiencing is a graphics bug caused by some of the post-processing effects. When this happens, you can try to change the resolution from the pause menu, it could fix the issue.

Also, I just uploaded a new game build, so maybe if you update it it could be better.

Let me know, thanks!

Can't play the game, I think its capturing the input from something plugged into my pc, but I can't figure out what. The view keeps moving up and to the left constantly.

Turns out it was a DS4 gamepad in another room, which was cabled but not actually generating any input when I check the controller readings. Must be some nonsense in how the engine interprets input (maybe deadzone?). Anyway, working now, sorry!

Ok haha, good to know you fixed it.

Hello!

I'm on a 2014 Macbook Pro running Mojave. I launch the game and everything's fine. The logos show up, as does the menu. I see the images drifting in the background. I start the game, I read the quote(s). And then it's just black. Always. I hear all the ambient noises in the background, but all I see is a black screen. I hit all the buttons in the instructions and nothing. When I pause, I see my cursor again, but it's still just a black screen.


I've tried the game from the itch launcher and from a separate download and I've tried playing around with the resolutions. Still just black. 


Have I missed something obvious and I'm an idiot or is there something wrong? Thanks!

Hey!

There's been a number of users on older mac versions who have run in many different problems. Unfortunately, since I don't have a Mac, I have not been able to help :(

Promesa can be heavy for graphics card... I can only recommend you to try to update your drivers.

Let me know how that goes and please ask for a refund if you're not able to play the game!

Have to keep the old OS because I have the kind of mac that might brick with the update. I'll try some other stuff, but if it doesn't work, keep the money. Support your indie devs and all that. 

I see... I hope you'll be able to play it in the future. And thank you!

Having trouble on  Microsoft Surface Pro 7 with Windows 10 - there's no mouse cursor available after starting Promesa and reaching the first lines of dialog. No way to move on. Touch screen doesn't respond either - but that's not important. The only option is to Alt-Tab and close the application. Any help? Very intrigued by this game and can't wait to play. Thanks.

During the dialogues the cursos doesn't show up: you're supposed to press X, Enter or Space.

Do you have a keyboard connected?

You could also try with a gamepad if you have one!

Let me know if a keyboard solves it :)

Thank you. That's what confused me. I had to click the mouse a few times to get started, and assumed that was the way to move forward. Yes, I do have a keyboard attached and look forward to getting started! Thanks again!

Controls are explained before pressing the start button :)